Autor Thema: T110 II - empfohlene BIOS-Einstellungen für Windows Server 2008 R2  (Gelesen 1160 mal)

Offline Aksel

Hallo alle zusammen,

welche BIOS-Einstellungen sind beim Poweredge T110 II sinnvoll wenn als Betriebssystem "Windows Server 2008 R2" installiert werden soll? Worauf ist zu achten?

Der Server soll als reiner Exchange-Server laufen, hat 32 GB RAM, 2x 500 GB HDD und den onboard Perc 100 Raid-Controller (softwarebasierend). Es gibt nur 5 Postfächer, insgesamt 10 Clients.

Würdet ihr RAID 1 über den onboard "RAID"-Controller realisieren oder lieber über Windows? Macht doch keinen Unterschied - oder?


Für die Installation habe ich mir die ISO-Dateien "Systems Build and Update Utility" und "Windows OS install support pack" heruntergeladen und auf DVD gebrannt. Wie geht ihr bei einer Neuinstallation von Windows Server 2008 R2 auf einen DELL-Server vor?
...

Bisher wurde alles über einen T710 (24 GB RAM, 4x SAS HDD Raid 10, Perc H700) mit SBS 2011 betrieben, auf diesem laufen z.Zt. zusätzlich zum Exchange noch ein Warenwirtschaftsprogramm und eine Datenbank. Immer wieder haben wir dort Performance-Einbrüche, so dass z.B. die Zugriffe quälend langsam laufen bzw. die Programme kurzzeitig "einfrieren".

Leider konnte bisher trotzt unterschiedlicher Computer-Dienstleister und 2x neuer Komplettinstallationen keine Abhilfe geschaffen werden. Jetzt die Überlegung, den T710 nur für das Warenwirtschaftsprogramm und Datenbank zu nutzen und den T110 zusätzlich als reiner Exchange-Server. Beide Server werden dann mit "Windows Server 2008 R2" laufen., also SBS 2011 fällt komplett weg. Entsprechende Lizenzen wurden bereits gekauft.

Bei Neukauf des T710 ist man davon ausgegangen, dass dieser alles leicht schaffen kann. Keiner weiss, warum es stockt, daher jetzt dieser Schritt.

Bin für jeden Tipp und Anregung dankbar!

Vielen Dank im Voraus,


Aksel

Offline Dayworker

Das Problem ist der SBS2011 bzw das darin enthaltene Exchange. Ohne RAM-Begrenzung knuspert das mit zunehmender Laufzeit sämtlichen freien Arbeitsspeicher und rückt den nur äusserst ungern wieder raus. Wenn man den begrenzt, läuft der SBS2011 zumindest mal ne Woche durch. Wir starten unseren jeden Sonntagabend durch, damit sowohl Exchange als auch unser in einer Hyper-V laufendes Warenwirtschaftssystem und eine Zeiterfassung nicht spätestens nach 10 Tagen die Zusammenarbeit verweigert.

Ein Raid10 nur aus der Mindestanzahl an nötigen Raidmitgliedern ist ungünstig, da es mit HDDs (mit SSDs sieht das schon anders aus, wenn man bei den empfehlenswerten Server-SSDs üblichen Preisen mit dem 50%igen Platzverschnitt leben kann) zuwenig Durchsatz bringt. Die IO-Geschwindigkeit kommt immer über die Spindelanzahl. Wenn du möglichst hohe IOPS brauchst, schalte am einfachsten eine SSD als Cache davor. In jedem Fall vergiß bloß nicht, den Write-Cache des Perc-H700 (das dieser per BBU bzw NV-Cache und USV abgesichert wird, setze ich voraus) einzuschalten. Ansonsten hängt der HW-Controller dank Write-Thru beständig bei deutlich über 90% Auslastung rum und ohne Plattencache sind dann IO-Werte um 15 Megabyte pro Sekunde als normal zu nennen.

Den T110 würde ich nicht unbedingt mit Exchange überfordern. Bei 5 Postfächern und 10 Clienten dürfte das aber noch immer ausreichen. Der H200-Controller hat (genau wie dein Chipsatz-Controller) keinen Cache und schaltet daher im Raidbetrieb den Plattencache aus Datensicherheitsgründen komplett ab. Wenn dir deine Daten lieb sind, läßt du ohne BBU (falls der Controller eine solche überhaupt unterstützt) und/oder-zumindest einer USV die Finger von jedwedem Raidbetrieb. Im Falle eines Spannungsversorgungsproblems könnte eine Platte schneller gewesen sein und dadurch ist die Datenkonsistenz dann nicht mehr gewahrt. Das ist aber noch nicht das Schlimmste. Beim anschließenden Raid-Rebuild siehst du nicht, welche Platte zuletzt noch sinnvolle Daten geschrieben hat und der Controller bzw Windows stellt dann ggf zwar die Datenkonsistenz wieder her, du mußt aber ggf mit unvollständigen Daten leben. Nicht nur Exchange fällt dann gern beim Reboot auf die Nase und bedarf manueller Nacharbeit.
Ob du das Raid1 nun im Chipsatz oder unter Windows aufbaust, macht in meinen Augen kaum einen Unterschied. Der Chipsatz-Controller ist in der Linux-Welt als Fake-Raid bekannt und auch wenn Linux inzwischen damit weitestgehend umzugehen weiß, wird das Raid unter Windows durch einen Treiber abgebildet. Je nach Controller macht man sich dann manchmal auch abhängig bei der maximalen Datenträgergrösse. Letzteres Problem gibt es in dieser Form meines Wissens beim durch Windows gebildeten Raid erstmal nicht, wenn wirklich nur die dem OS beiliegenden Treiber genutzt werden und auch der Plattencache bleibt aktiviert. Das sorgt aufgrund des Windows-Dateisystemcaches für die übliche, normale Geschwindigkeit und ohne USV lebst du bei Raideinsatz immer am Rande eines möglichen Datenverlustes. Beim Raid1 kannst du je nach Intelligenz bei der Raid-Mitgliederansteuerung beim Lesen maximal die doppelte IO-Rate und beim Schreiben höchstens die IO-Rate eines Einzellaufwerks erwarten. Der Controller meldet erst dann Schreibvollzug an das Betriebssystem, wenn beide Raidmitgleider bereits Vollzug gemeldet haben und das dauert halt auch etwas.


Wenn der T110 noch nicht gekauft ist, würde ich es erstmal mit der SBS-Optimierung versuchen. Der H700-Controller hat zumindest mit NV-Flash und aktiviertem Write-Cache genügend Power, dein jetziges System flüssig auszuführen.
KEIN SUPPORT PER PN !

Dateiuploads bitte verlinken!

T110ii, E3-1220v2, 24GB, H200 mit LSI9211 IT-FW P19, Napp-it AiO 18.12r1, ESXi6.5U2 free